EURid Registry Maintenance (.EU)

Scheduled for Oct 1, 04:00 - 07:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2025 - 14:58 UTC

Scheduled

Environment: Production
Impact: Domain availability checks, Registrations, Renewals, and Management: Unavailable
WHOIS/RDAP: unavailable
DNS: not impacted
Affected TLDs: EU
Posted Sep 10, 2025 - 14:56 UTC
This scheduled maintenance affects: name.com Registry Connections.