.Space DNS resolution degraded

Incident Report for namecom

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 16:06 UTC

Monitoring

The registry operator for .space has encountered degraded DNS resolution on .space domains. We will update as soon as we receive another update from the .space registry with updates
Posted Sep 24, 2025 - 15:32 UTC
This incident affected: name.com Registry Connections.